Core Platform currently experiencing outages
Incident Report for LaterPay Inc
Resolved
This incident has been resolved.
Posted May 07, 2019 - 09:34 UTC
Monitoring
We have addressed the issue but are continuing to monitor.
Posted May 03, 2019 - 18:42 UTC
Update
We are continuing to investigate this issue.
Posted May 03, 2019 - 18:17 UTC
Investigating
We are currently experiencing intermittent outages with our core platform. Engineers have been dispatched and are working to mitigate it as quickly as possible.
Posted May 03, 2019 - 18:17 UTC
This incident affected: Production Platform.