Users are unable to pay for content
Incident Report for LaterPay Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. May 28, 2018 - 07:27 UTC
Update
The issue seems to have resolved itself automatically, and payment service has been restored.
Posted over 1 year ago. May 28, 2018 - 07:20 UTC
Investigating
We are currently investigating this issue.
Posted over 1 year ago. May 25, 2018 - 23:33 UTC
This incident affected: Production Platform.