Problems attaching Terms and Conditions to Subscriptions
Incident Report for LaterPay Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 12, 2018 - 17:19 UTC
Update
We are continuing to investigate this issue.
Posted over 1 year ago. Jun 12, 2018 - 16:52 UTC
Investigating
We are currently experiencing issues attaching Terms and Conditions to subscriptions. Engineers are working on a fix.
Posted over 1 year ago. Jun 12, 2018 - 16:51 UTC
This incident affected: Production Platform.