Merchant sign up glitch
Incident Report for LaterPay Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Dec 07, 2018 - 14:30 UTC
Update
We've identified the issue that results in newly signed up merchant users being redirected back to the registration form instead of their merchant dashboard. We're working on a fix.
Posted 10 months ago. Dec 07, 2018 - 09:28 UTC
Investigating
We’re currently investigating an issue that prevents users from completing their sign up successfully as a merchant.
Posted 10 months ago. Dec 07, 2018 - 08:07 UTC
This incident affected: Production Platform and Sandbox Platform.