Merchant signups not working on website
Incident Report for LaterPay Inc
Resolved
The issue preventing merchant signups in the US region has been resolved.
Posted about 1 year ago. Sep 19, 2018 - 13:20 UTC
Investigating
We are currently experiencing some technical issues preventing merchant signups for the USA on our website. If you are based in the USA and want to signup as a merchant please contact support@laterpay.net
Posted about 1 year ago. Sep 19, 2018 - 07:49 UTC
This incident affected: Homepage.